题目来源:http://poj.org/problem?id=2524
Description
There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7
Hint
Huge input, scanf is recommended
注意,题目提示用scanf,而我却用了cin,因此我的ac差一点点就超时了(用了4500ms),换成scanf,就只需要340ms了,速度提高了十几倍啊,看来IO速度差距不小啊。
下面是我的AC代码:
#include"iostream"
using namespace std;
const int MAX_SIZE = 50001;
class ufs
{
public:
int ancestor[MAX_SIZE];
int degree[MAX_SIZE];
int groups;
void makeset();
int findset(const int& x);
void Union(const int& x,const int &y);
};
void ufs::makeset()
{
for(int i =0;i<MAX_SIZE;++i)
{
ancestor[i] = i;
degree[i] = 0;
}
}
int ufs::findset(const int& x)
{
if(ancestor[x] !=x)
{
ancestor[x] = findset(ancestor[x]);
}
return ancestor[x];
}
void ufs::Union(const int& x,const int& y)
{
int xancestor = findset(x);
int yancestor = findset(y);
if(xancestor == yancestor)
{
return;
}
if(degree[xancestor] > degree[yancestor])
{
ancestor[yancestor] = xancestor;
groups--;
}
else
{
if(degree[xancestor] == degree[yancestor])
{
degree[yancestor] += 1;
}
ancestor[xancestor] = yancestor;
groups--;
}
}
int Case =0;
int n,m;
int main(void)
{
ufs UFS;
int x,y;
while(cin>>n>>m && !(n==0&&m==0))
{
UFS.groups = n;
Case++;
UFS.makeset();
for(int i =0;i<m;++i)
{
cin>>x>>y;
UFS.Union(x,y);
}
cout<<"Case "<<Case<<": "<<UFS.groups<<endl;
}
return 0;
}