ACM&&树形DP

Strategic game
Time Limit: 2000MS
Memory Limit: 10000K
Total Submissions: 3555
Accepted: 1556

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:
ACM&&树形DP_第1张图片
the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:

  • the number of nodes
  • the description of each node in the following format
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads

    or
    node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

Source

Southeastern Europe 2000


/*
ans[i][0]表示在不选择节点i的情况下,以i为根节点的子树,最少需要选择的点数;

ans[i][1]表示在选择节点i的情况下,以i为根节点的子树,最少需要选择的点数;

当i是叶子时,ans[i][0]=0,ans[i][1]=1;

else

ans[i][0]=sigma(ans[j][1])(j为i的子节点)

ans[i][1]=1+sigmamin(ans[j][0],ans[j][1]);
 */

#include<iostream>
#include<cstdio>
using namespace std;
int min(int a,int b)
{
  if(a>b) return b;
  else return a;
}
int dp[1505][2];
int child[1505];
int pos[1505];
struct EDGE
{
  int from,to;
}edge[1505];
void FindDp(int st)//递归时是把st压入栈中的,不是to
{
  int to;
  dp[st][0] = 0;                                                                
  dp[st][1] = 1;                                      
  if(child[st] == 0) return ;//当递归到叶子节点就返回
  int i = pos[st];
  while(edge[i].from == st)
    {
      to = edge[i++].to;
      FindDp(to);//从儿子节点继续递归搜
      dp[st][0] += dp[to][1];
      dp[st][1] += min(dp[to][0],dp[to][1]);
    }
}
int main()
{
  int n;
  int parent,sum;
  int num;
  int t,count,level;
  while(scanf("%d",&n) != EOF)
    {
      num = level = 0;
      count = 1;
      for(int j =1;j<=n;j++)
    {
      scanf("%d:(%d)",&parent,&sum);
      num += parent;
      pos[parent] = count;
      child[parent] = sum;
      for(int i =1;i <= sum;i++)
        {
          scanf("%d",&t);
          level += t;
          edge[count].from = parent;
          edge[count++].to = t;
        }
    }
      int find = num - level;//记录根节点
      FindDp(find);//从根节点开始递归
      printf("%d\n",min(dp[find][0],dp[find][1]));
    }
}



你可能感兴趣的:(ACM&&树形DP)