HDU3665:Seaside

点击打开题目链接

Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 955    Accepted Submission(s): 679


Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S Mi and L Mi, which means that the distance between the i-th town and the S Mi town is L Mi.
 

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
 

Sample Input
       
       
       
       
5 1 0 1 1 2 0 2 3 3 1 1 1 4 100 0 1 0 1
 

Sample Output
       
       
       
       
2
 

Source
2010 Asia Regional Harbin
 

Recommend
lcy
 


=====================================题目大意=====================================


已知每个城镇是否临海以及从该城镇出发的所有道路的长度和终点,计算从小Y家(编号为0的城镇)去海边的最短路线长度。


=====================================算法分析=====================================


引入编号为N的城镇"海”,为临海的城镇增加长度为0终点为“海”的道路,然后Dijkstra求解城镇0至城镇N的最短路即可。


=======================================代码=======================================




#include<queue>
#include<cstdio>
#include<cstring>

using namespace std;

const int INF1=0x1f;
const int MAXN=105;

int N,Edge[MAXN][MAXN],Dis[MAXN];

bool Vis[MAXN];

struct NODE  
{  
	NODE(int P,int D) { Pt=P;  Dis=D; }
    friend bool operator < (const NODE& A,const NODE& B) { return A.Dis>B.Dis; }  
	int Pt,Dis;
};  

void Dijkstra()
{
	memset(Vis,0,sizeof(Vis));
	memset(Dis,INF1,sizeof(Dis));
	priority_queue<NODE>q;
	q.push(NODE(0,Dis[0]=0));
    while(!q.empty())  
    {  
        NODE cur=q.top();  q.pop();  
        if(cur.Pt==N)   { return; }  
		if(Vis[cur.Pt]) { continue; }
		Vis[cur.Pt]=1;
        for(int tmp=0;tmp<=N;++tmp)  
        {   
            if(Edge[cur.Pt][tmp]<Dis[tmp]-cur.Dis)     
            {  
                Dis[tmp]=cur.Dis+Edge[cur.Pt][tmp];
                q.push(NODE(tmp,Dis[tmp]));  
            }  
        }  
    }  
} 

int main()
{
	while(scanf("%d",&N)==1)
	{
		memset(Edge,INF1,sizeof(Edge));
		for(int i=0;i<N;++i)
		{
			int M,P;
			scanf("%d%d",&M,&P);
			if(P) { Edge[i][N]=0; }
			while(M--)
			{
				int S,L;
				scanf("%d%d",&S,&L);
				if(Edge[i][S]>L) { Edge[i][S]=L; }
			}
		}
		Dijkstra();
		printf("%d\n",Dis[N]);
	}
	return 0;
}

你可能感兴趣的:(图论,最短路)