动态规划 2845 Beans

              这道题数据坑爹,,,有木有!!!!!!题目只说了M*N<=200000,没说M和N的具体范围,,有木有因为这个wa的???有木有???我就因为这个wa了好几次,刚开始开的是1005的二维数组,一直wa,纠结了好久,找不到错误。后来抱着尝试的心态把1005改成2005就ac了,,,坑爹啊!就题目来说,我是先用动态规划把每一行的最大值求出来,然后再用动态规划的方法把n行的最大值求出来。简单来说,就是求出行的最大值,再求出列的最大值即可。题目:

Beans

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1121    Accepted Submission(s): 586


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
动态规划 2845 Beans_第1张图片

Now, how much qualities can you eat and then get ?
 

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
 

Output
For each case, you just output the MAX qualities you can eat and then get.
 

Sample Input
   
   
   
   
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
 

Sample Output
   
   
   
   
242
ac代码:
#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
const int N=2005;
int num[N][N],dprow[N],dpcol[N],dpp[N];
int n,m;
int max(int a,int b){
  return a>b?a:b;
}
void getdprow(){
	for(int i=1;i<=n;++i){
		memset(dpp,0,sizeof(dpp));
		dpp[1]=num[i][1];
		for(int j=2;j<=m;++j){
		  dpp[j]=max(dpp[j-1],dpp[j-2]+num[i][j]);
		}
		dprow[i]=dpp[m];
	}
}
void getdpcol(){
  dpcol[1]=dprow[1];
  for(int j=2;j<=n;++j){
    dpcol[j]=max(dpcol[j-1],dpcol[j-2]+dprow[j]);
  }
}
int main(){
	//freopen("4.txt","r",stdin);
  while(scanf("%d%d",&n,&m)!=EOF){
    memset(num,0,sizeof(num));
	memset(dprow,0,sizeof(dprow));
	memset(dpcol,0,sizeof(dpcol));
	for(int i=1;i<=n;++i){
	  for(int j=1;j<=m;++j)
		  scanf("%d",&num[i][j]);
	}
	getdprow();
	getdpcol();
	printf("%d\n",dpcol[n]);
  }
  return 0;
}


你可能感兴趣的:(动态规划 2845 Beans)