【POJ 1961】Period(KMP求循环节)

【POJ 1961】Period(KMP求循环节)

Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 15466   Accepted: 7417

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source

Southeastern Europe 2004

2406的升级版,串长i循环跑一遍即可,其他参见2406


代码如下:

#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const int mod = 1e9+7;
const double eps = 1e-8;

char str[2333333];
int Next[2333333];
int n;

void GetNext()
{
	int j,i = 0;
	j = Next[0] = -1;

	while(i < n)
	{
		while(j != -1 && str[i] != str[j]) j = Next[j];
		++i,++j;
		Next[i] = j;
	}
}

int main()
{
	//fread();
	//fwrite();
	int z = 1;

	while(~scanf("%d",&n) && n)
	{
		scanf("%s",str);
		GetNext();

		printf("Test case #%d\n",z++);
		for(int i = 1; i <= n; ++i)
		{
			int len = i-Next[i];
			if(i != len && i%len == 0)
				printf("%d %d\n",i,i/len);
		}
		puts("");
	}

	return 0;
}




你可能感兴趣的:(【POJ 1961】Period(KMP求循环节))