转载请注明出处:http://blog.csdn.net/jiangshibiao/article/details/24287865
【原题】
1629: [Usaco2007 Demo]Cow Acrobats
Time Limit: 5 Sec
Memory Limit: 64 MB
Submit: 548
Solved: 279
[ Submit][ Status]
Description
Farmer John's N (1 <= N <= 50,000) cows (numbered 1..N) are planning to run away and join the circus. Their hoofed feet prevent them from tightrope walking and swinging from the trapeze (and their last attempt at firing a cow out of a cannon met with a dismal failure). Thus, they have decided to practice performing acrobatic stunts. The cows aren't terribly creative and have only come up with one acrobatic stunt: standing on top of each other to form a vertical stack of some height. The cows are trying to figure out the order in which they should arrange themselves within this stack. Each of the N cows has an associated weight (1 <= W_i <= 10,000) and strength (1 <= S_i <= 1,000,000,000). The risk of a cow collapsing is equal to the combined weight of all cows on top of her (not including her own weight, of course) minus her strength (so that a stronger cow has a lower risk). Your task is to determine an ordering of the cows that minimizes the greatest risk of collapse for any of the cows. //有三个头牛,下面三行二个数分别代表其体重及力量 //它们玩叠罗汉的游戏,每个牛的危险值等于它上面的牛的体重总和减去它的力量值,因为它要扛起上面所有的牛嘛. //求所有方案中危险值最大的最小
Input
* Line 1: A single line with the integer N. * Lines 2..N+1: Line i+1 describes cow i with two space-separated integers, W_i and S_i.
Output
* Line 1: A single integer, giving the largest risk of all the cows in any optimal ordering that minimizes the risk.
Sample Input
3
10 3
2 5
3 3
Sample Output
2
OUTPUT DETAILS:
Put the cow with weight 10 on the bottom. She will carry the other
two cows, so the risk of her collapsing is 2+3-3=2. The other cows
have lower risk of collapsing.
HINT
Source
【分析】一看数据范围就是知道是贪心题,排个序就行了。于是磨磨蹭蹭地证了一下。假设我们必须把A放在B的上面。设A的重量和力量是w1,s1,B的是w2,s2。如果A在上面,B的危险值就是S+w1-a2.(其中S是之前的奶牛重量和)。如果A在下面,A的危险值就是S+w2-a1.因为A在B上面更优,所以S+w1-a2<=s+w2-a1,整理后可得:w1+a1<=w2+a2。因此,我们要把总和小的放在前面!
【代码】
#include<cstdio>
#include<algorithm>
using namespace std;
struct arr{int w,s;}a[50005];
int n,i,sum,ans;
bool cmp(arr a,arr b){return a.w+a.s<b.w+b.s;}
int main()
{
scanf("%d",&n);
for (i=1;i<=n;i++)
scanf("%d%d",&a[i].w,&a[i].s);
sort(a+1,a+n+1,cmp);ans=-a[1].s;
for (i=2;i<=n;i++)
sum+=a[i-1].w,ans=max(ans,sum-a[i].s);
printf("%d",ans);
return 0;
}