HDU1358:Period

Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K  , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
   
   
   
   
3 aaa 12 aabaabaabaab 0
 

Sample Output
   
   
   
   
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 


 

//一开始完全没有看懂题目的意思,就是说从字符串的第二个开始,看前面是循环串吗,是的话就输出此时的位置,和循环串的周期,周期必须大于1

 


/*
对next的理解更深入了点儿。
    字符编号从0开始,那么if(i%(i-next[i])==0),则i前面的
串为一个轮回串,其中轮回子串出现i/(i-next[i])次。
*/


 

#include <string.h>
#include <iostream>
#include <stdio.h>

char str[1000005];
int next[1000005];

void getnext()
{
    int i = 0,j = -1;
    memset(next,0,sizeof(next));
    next[0] = -1;
    while (str[i])
    {
        if(j == -1 || str[i] == str[j])
        {
            i++;
            j++;
            next[i] = j;
        }
        else
        j = next[j];
    }
}

void kmp()
{
    int i,t;
    for(i = 2;str[i-1];i++)
    {
        t = i-next[i];
        if(i%t == 0 && i/t>1)
        printf("%d %d\n",i,i/t);
    }
}

int main()
{
    int n,cnt = 1;

    while(scanf("%d",&n)!=EOF && n)
    {
        scanf("%s",str);
        printf("Test case #%d\n",cnt++);
        getnext();
        kmp();
        putchar(10);
    }

    return 0;
}



 

你可能感兴趣的:(KMP,ACM,HDU,杭电,解题报告)