最小树形图uva11183

Problem I
Teen Girl Squad 
Input: Standard Input Output: Standard Output 

You are part of a group of n teenage girls armed with cellphones. You have some news you want to tell everyone in the group. The problem is that no two of you are in the same room, and you must communicate using only cellphones. What's worse is that due to excessive usage, your parents have refused to pay your cellphone bills, so you must distribute the news by calling each other in the cheapest possible way. You will call several of your friends, they will call some of their friends, and so on until everyone in the group hears the news.

Each of you is using a different phone service provider, and you know the price of girl A calling girl B for all possible A and B. Not all of your friends like each other, and some of them will never call people they don't like. Your job is to find the cheapest possible sequence of calls so that the news spreads from you to all n-1 other members of the group.

Input

The first line of input gives the number of cases, (N<150). N test cases follow. Each one starts with two lines containing n (0<=n<=1000)and m (0 <= m <= 40,000). Girls are numbered from 0 to n-1, and you are girl 0. The next m lines will each contain 3 integers, uv and w, meaning that a call from girl u to girl v costs w cents (0 <= w <= 1000). No other calls are possible because of grudges, rivalries and because they are, like, lame. The input file size is around 1200 KB.

Output

For each test case, output one line containing "Case #x:" followed by the cost of the cheapest method of distributing the news. If there is no solution, print "Possums!" 

 instead.Sample Input

4

2

1

0 1 10

2

1

1 0 10

4

4

0 1 10

0 2 10

1 3 20

2 3 30

4

4

0 1 10

1 2 20

2 0 30

2 3 100

Sample Output

Case #1: 10

Case #2: Possums!

Case #3: 40

Case #4: 130

有向图最小生成树

#include <iostream>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn=1010;
const  int maxm=40050;
const int inf=0x3f3f3f3f;
int g[maxn][maxn];
struct Edge
{
    int u,v,cost;
}edge[maxm];
int pre[maxn],id[maxn],visit[maxn],in[maxn];
int zhuliu(int root,int n,int m,Edge edge[])
{
    int res=0,u,v;
    while(1)
    {
        for(int i=0;i<n;i++)
            in[i]=inf;
        for(int i=0;i<m;i++)
            if(edge[i].u!=edge[i].v&&edge[i].cost<in[edge[i].v])
        {
            pre[edge[i].v]=edge[i].u;
            in[edge[i].v]=edge[i].cost;
        }
        for(int i=0;i<n;i++)
        {
            if(i!=root&&in[i]==inf)
                return -1;
        }
        int tn=0;
        memset(id,-1,sizeof(id));
        memset(visit,-1,sizeof(visit));
        in[root]=0;
        for(int i=0;i<n;i++)
        {
            res+=in[i];
            v=i;
            while(visit[v]!=i&&id[v]==-1&&v!=root)
            {
                visit[v]=i;
                v=pre[v];
            }
            if(v!=root&&id[v]==-1)
            {
                for(int u=pre[v];u!=v;u=pre[u])
                id[u]=tn;
                id[v]=tn++;
            }
        }
        if(tn==0)
            break;///没有有向环
        for(int i=0;i<n;i++)
        if(id[i]==-1)
            id[i]=tn++;
        for(int i=0;i<m;)
        {
            v=edge[i].v;
            edge[i].u=id[edge[i].u];
            edge[i].v=id[edge[i].v];
            if(edge[i].u!=edge[i].v)
                edge[i++].cost-=in[v];
            else
                swap(edge[i],edge[--m]);
        }
        n=tn;
        root=id[root];

    }
    return res;
}
int main()
{
    int n,m;
    int Case=0;
    int T;
    cin>>T;
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
                g[i][j]=inf;
        }
        int l=0;
        for(int i=0; i<m; i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            edge[l].u=u;
            edge[l].v=v;
            if(u==v)
                edge[l++].cost=inf;
            else
                edge[l++].cost=w;
        }
        int ans=zhuliu(0,n,l,edge);
        printf("Case #%d: ",++Case);
        if(ans==-1)
            printf("Possums!\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}


 

你可能感兴趣的:(最小树形图uva11183)