ZOJ 2736 Daffodil number

E - Daffodil number
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu
Submit Status Practice ZOJ 2736

Description

The daffodil number is one of the famous interesting numbers in the mathematical world. A daffodil number is a three-digit number whose value is equal to the sum of cubes of each digit.

For example. 153 is a daffodil as 153 = 13 + 53 + 33.

Input

There are several test cases in the input, each case contains a three-digit number.

Output

One line for each case. if the given number is a daffodil number, then output "Yes", otherwise "No".

Sample Input

153
610

Sample Output

Yes
No

代码:

#include<iostream>
using namespace std;
int main()
{
    int n;
    int a,b,c;
    while(cin>>n)
    {
        a=n%10;
        b=(n/10)%10;
        c=n/100;
        if(a*a*a+b*b*b+c*c*c==n)
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
    }
    return 0;
}


你可能感兴趣的:(ZOJ)