Last non-zero Digit in N!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7146 Accepted Submission(s): 1797
Problem Description
The expression N!, read as "N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,
N N!
0 1
1 1
2 2
3 6
4 24
5 120
10 3628800
For this problem, you are to write a program that can compute the last non-zero digit of the factorial for N. For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce "2" because 5! = 120, and 2 is the last nonzero digit of 120.
Input
Input to the program is a series of nonnegative integers, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.
Output
For each integer input, the program should print exactly one line of output containing the single last non-zero digit of N!.
Sample Input
Sample Output
Source
South Central USA 1997
解题思路:
就是求阶乘的最后非零解,总结摸板,以后可以直接用。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define maxn 10000
using namespace std;
char map[100000];
int lastdigit(char *buf)
{
int mod[20]={1,1,2,6,4,2,2,4,2,8,4,4,8,4,6,8,8,6,8,2};
int len=strlen(buf),a[maxn],i,c,ret=1;
if(len==1)
{
return mod[buf[0]-'0'];
}
for(i=0;i<len;i++)
{
a[i]=buf[len-1-i]-'0';
}
for(;len;len-=!a[len-1])
{
ret=ret*mod[a[1]%2*10+a[0]]%5;
for(c=0,i=len-1;i>=0;i--)
{
c=c*10+a[i],a[i]=c/5,c%=5;
}
}
return ret+ret%2*5;
}
int main()
{
while(scanf("%s",map)!=EOF)
{
printf("%d\n",lastdigit(map));
}
return 0;
}