HDU 1517 A Multiplication Game 小聪明博弈

A Multiplication Game
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  HDU 1517
Appoint description:  System Crawler  (2016-04-20)

Description

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n. 
 

Input

Each line of input contains one integer number n. 
 

Output

For each line of input output one line either 

Stan wins. 

or 

Ollie wins. 

assuming that both of them play perfectly. 
 

Sample Input

      
      
      
      
162 17 34012226
 

Sample Output

      
      
      
      
Stan wins. Ollie wins. Stan wins.
 

        实际上我更愿意把这道题目看作是一道耍小聪明的游戏,我们每个人心中都有一个小算盘,设身处地的想,就能找到问题的关键。

        下面正式分析一下,2--9内。s必胜;超过9,那么s必定选2,也就是说在10--9*2内,o必胜;超过18,s就可以通过控制第一次的取值来获胜,最大就是9*2*9;我们可以看到,每乘18就会循环一轮,所以只需要让n不断除以18,最后判断是落在1--9还是10--18里就可以了,注意,由于存在除不尽的情况,需要将n设置为double

#include <stdio.h>
int main()
{
        double n;
        while(~scanf("%lf",&n))
        {
                while(n>18)
                        n/=18;
                if(n>=1&&n<=9)
                        printf("Stan wins.\n");
                else
                        printf("Ollie wins.\n");
        }
        return 0;
}



你可能感兴趣的:(HDU,a,Multiplication,GAM,小聪明博弈,1517)