HDU1232畅通工程 并查集

畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41588    Accepted Submission(s): 22070


Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。 
 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。 
 

Sample Input
   
   
   
   
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 

Sample Output
   
   
   
   
1 0 2 998
Hint
Hint
Huge input, scanf is recommended.
 
并查集的基础题目,给定N个点与M条道路,找出最后还剩C个集合,用C-1条道路将他们连起来即可。
//************************************************************************//
//*Author : Handsome How										       	 *//
//************************************************************************//
#pragma warning(disable:4996) 
//#pragma comment(linker, "/STA	CK:1024000000,1024000000")
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <complex>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <ctime>                                                
#include <cassert>
using namespace std;
typedef long long LL;
const int MAXN = 1000 + 10;
int city, road;
int father[MAXN];
int findfather(int n)
{
	int f=n;
	while (f!=father[f])
		f = father[f];	  //找父亲
	int t=n, x;
	while (t!=f)
	{
		x = father[t];
		father[t] = f;
		t = x;
	} 				   //压缩路径
	return f;
}

int main()
{
	//freopen("E:\\data.in", "r", stdin);
	//freopen("E:\\data.out", "w", stdout);
	while (scanf("%d", &city) != EOF)
	{				  
		if (city == 0)break;
		int ans = 0;
		scanf("%d", &road);
		for (int i = 1; i <= city; i++)
			father[i] = i;
		while (road--)
		{
			int a, b;
			scanf("%d", &a);
			a = findfather(a);
			scanf("%d", &b);
			b = findfather(b);
			father[a] = b;
		}
		for (int i = 1; i <= city; i++)
			if (i == father[i])
			ans++;
		printf("%d\n",ans-1);
	}
	return 0;
}



你可能感兴趣的:(并查集)