ZOJ 3699 Dakar Rally(贪心算法)

Dakar Rally
Time Limit: 2 Seconds Memory Limit: 65536 KB
Description

The Dakar Rally is an annual Dakar Series rally raid type of off-road race, organized by the Amaury Sport Organization. The off-road endurance race consists of a series of routes. In different routes, the competitors cross dunes, mud, camel grass, rocks, erg and so on.

Because of the various circumstances, the mileages consume of the car and the prices of gas vary from each other. Please help the competitors to minimize their payment on gas.

Assume that the car begins with an empty tank and each gas station has infinite gas. The racers need to finish all the routes in order as the test case descripts.

Input

There are multiple test cases. The first line of input contains an integer T (T ≤ 50) indicating the number of test cases. Then T test cases follow.

The first line of each case contains two integers: n – amount of routes in the race; capacity – the capacity of the tank.

The following n lines contain three integers each: mileagei – the mileage of the ith route; consumei – the mileage consume of the car in the ith route , which means the number of gas unit the car consumes in 1 mile; pricei – the price of unit gas in the gas station which locates at the beginning of the ith route.

All integers are positive and no more than 105.

Output

For each test case, print the minimal cost to finish all of the n routes. If it’s impossible, print “Impossible” (without the quotes).

Sample Input

2
2 30
5 6 9
4 7 10
2 30
5 6 9
4 8 10
Sample Output

550
Impossible

下面是AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#define maxn 100005
using namespace std;

int len[maxn],cost[maxn],price[maxn];
int main()
{
    int t,n,v;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&v);
        int flag=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d%d",&len[i],&cost[i],&price[i]);
            if(len[i]*cost[i]>v)
            {
                flag=1;
            }
        }
        if(flag)
        {
            printf("Impossible\n");
            continue;
        }
        int i=0,j;
        long long rest=0,sum=0,t;
        while(i<n)
        {
            j=i+1,t=len[i]*cost[i];
            while(j<n&&(price[j]>=price[i])&&(v>=t+cost[j]*len[j]))
            {
                t+=len[j]*cost[j];
                j++;
            }
            if(j>=n||price[j]<price[i])//能找到便宜的点或者能跑完全程
            {
                if(rest>t)
                {
                    rest-=t;
                }
                else
                {
                    sum+=(t-rest)*price[i];
                    rest=0;
                }
                i=j;//更新当前点
            }
            else//把现在的油用完都没找到油更便宜的点的话,就在现在的点把油箱加满
            {
                sum+=(v-rest)*price[i];
                rest=v-len[i]*cost[i];
                i++;
            }
        }
        printf("%lld\n",sum);
    }
    return 0;
}

你可能感兴趣的:(ZOJ)