M - A Knight's Journey

M - A Knight's Journey
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:

A1B3C1A2B4C2A3B1C3A4B2C4

比较坑,首先输入的时候,先输入的是列,不是排。其次要按字典序排,刚开始不知道怎么排,看了别人的博客,才知道要按

(-1,-2 ,1,-2 , -2,-1, 2,-1,  -2,1 ,2,1 ,-1,2, 1,2)的方向进行搜索,这样搜到的第一个就是按字典序排的。

      
      
      
      
#include<stdio.h>
#include<string.h>
int fx[8][2]= {-1,-2 ,1,-2 , -2,-1, 2,-1,  -2,1 ,2,1 ,-1,2, 1,2};
int a[20][20],b1[1000][2],x1,y1,f;
void dfs(int x,int y,int c)
{
//    printf("%d ",c);
    int i,j;
    if(c==x1*y1&&!f)
    {
        for(i=0; i<c; i++)
        {
            f=1;
            printf("%c%d",b1[i][1]+'A'-1,b1[i][0]);
        }
        return;
    }
    else
        for(i=0; i<8; i++)
        {
            if(  x+fx[i][0]>0&&x+fx[i][0]<=x1  &&   y+fx[i][1]>0&&y+fx[i][1]<=y1  &&!a[x+fx[i][0]][y+fx[i][1]])
            {
                b1[c][0]=x+fx[i][0];
                b1[c][1]=y+fx[i][1];
                a[x+fx[i][0]][y+fx[i][1]]=1;
                dfs(x+fx[i][0],y+fx[i][1],c+1);
                a[x+fx[i][0]][y+fx[i][1]]=0;
            }
        }
}
int main()
{
    int N,S;
    scanf("%d",&N);
    S=N;
    while(N--)
    {
        f=0;
        memset(a,0,sizeof(a));
        scanf("%d%d",&x1,&y1);
        b1[0][0]=1,b1[0][1]=1;
        printf("Scenario #%d:\n",S-N);
        a[1][1]=1;
        dfs(1,1,1);
        if(!f)
            printf("impossible");
        printf("\n\n");
    }
}


 

你可能感兴趣的:(递归,搜索)