POJ1611 The Suspects

The Suspects
Time Limit: 1000MS   Memory Limit: 20000K
Total Submissions: 30212   Accepted: 14692

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003


    这道题当时抽风了,没有想到在最后进行find操作,可能并查集用的不够灵活吧,在最后一次进行find时,只要与0是一组的话,终究是能查找出来的。=_=

代码如下:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define maxn 30005
using namespace std;

int mem[maxn];

inline void init(int n)
{
	for(int i=0;i<n;i++)
		mem[i]=i;
}

int find(int x)
{
	return mem[x]==x?x:find(mem[x]);
}

int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(!n && !m) break;
		init(n);
		while(m--)
		{
			int k,tem[maxn];
			scanf("%d",&k);
			for(int i=0;i<k;i++)
				scanf("%d",&tem[i]);
			sort(tem,tem+k);
			for(int i=1;i<k;i++)
			{
				int x=find(tem[i-1]);
				int y=find(tem[i]);
				mem[y]=x;
			}
		}
		int ans=0;
		for(int i=0;i<n;i++)
		{
			if(find(i)==find(0)) ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}

你可能感兴趣的:(并查集)