(深搜) — — hdu 1016

Prime Ring Problem


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

(深搜) — — hdu 1016_第1张图片
 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
   
   
   
   
6 8
 

Sample Output
   
   
   
   
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016


坑啊,就多输出一个空格,一直没有AC,浪费了我好长时间的,切记切记看好输出


#include<stdio.h>
#include<string.h>
int p[100],a[30],n;
int prim(int x){
	if(x<2)	return 0;
	for(int i=2;i<x;i++)
		if(x%i==0)	return 0;
	return 1; 
}
void find(int q){
	
	if(q==n+1 && prim(a[n]+a[1])){
		printf("%d",a[1]);
		for(int i=2;i<=n;i++){
			printf(" %d",a[i]);
		}
		printf("\n");
		return ;
	}
	if(q==n+1)	return ;
	for(int i=2;i<=n;i++){
		if(prim(i+a[q-1])){
			if(!p[i]){
				a[q]=i;
				p[i]=1;
				find(q+1);
				p[i]=0;
			}
		}
	}
	
}

int main()
{
	int k=1;
	while(~scanf("%d",&n)){
		memset(p,0,sizeof(p));
		printf("Case %d:\n",k++);
		a[1]=1;
		if(n%2==0)	find(2);
		printf("\n");	
	}
	return 0;
}




你可能感兴趣的:(搜索)