nyoj 82

迷宫寻宝(一)

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

一个叫ACM的寻宝者找到了一个藏宝图,它根据藏宝图找到了一个迷宫,这是一个很特别的迷宫,迷宫里有N个编过号的门(N<=5),它们分别被编号为A,B,C,D,E.为了找到宝藏,ACM必须打开门,但是,开门之前必须在迷宫里找到这个打开这个门所需的所有钥匙(每个门都至少有一把钥匙),例如:现在A门有三把钥匙,ACM就必须找全三把钥匙才能打开A门。现在请你编写一个程序来告诉ACM,他能不能顺利的得到宝藏。

 

输入
输入可能会有多组测试数据(不超过10组)。
每组测试数据的第一行包含了两个整数M,N(1<N,M<20),分别代表了迷宫的行和列。接下来的M每行有N个字符,描述了迷宫的布局。其中每个字符的含义如下:
.表示可以走的路
S:表示ACM的出发点
G表示宝藏的位置
X表示这里有墙,ACM无法进入或者穿过。
A,B,C,D,E表示这里是门,a,b,c,d,e表示对应大写字母的门上的钥匙。
注意ACM只能在迷宫里向上下左右四个方向移动。

最后,输入0 0表示输入结束。
输出
每行输出一个YES表示ACM能找到宝藏,输出NO表示ACM找不到宝藏。
样例输入
4 4 
S.X. 
a.X. 
..XG 
.... 
3 4 
S.Xa 
.aXB 
b.AG 
0 0
样例输出
YES 

NO


解题思路:这道题目唯一要注意的就是门的钥匙必须都要拿到才能打开,所以弄一个数组记录下钥匙的个数,每次遇到一个钥匙就减一次,并且把这一点置为'.',由于可能某一点会出现多次,而钥匙的种类也小于5,所以可以状态压缩,每一种钥匙代表一个位,防止重复。。。

我测的很多数据都过了,就是一直WA......


#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

int n,m,sx,sy,ex,ey;
int dir[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};
int num[5];
char map[20][20];
bool vis[20][20][50],door[5];
struct node
{
	int x,y;
	int status;
};

bool bfs()
{
	queue<node> q;
	node cur,next;
	int x,y,status;
	cur.x = sx; cur.y = sy; cur.status = 0;
	q.push(cur);
	while(!q.empty())
	{
		cur = q.front();
		q.pop();
		for(int i = 0; i < 4; i++)
		{
			x = cur.x + dir[i][0];
			y = cur.y + dir[i][1];
			status = cur.status;
			if(x == ex && y == ey) return true;
			if(x < 0 || x >= m || y < 0 || y >= n || map[x][y] == 'X') continue;
			if(map[x][y] == '.')
			{
				if(vis[x][y][status] == true) continue;
				next.x = x; next.y = y; next.status = status;
				vis[x][y][status] = true;
				q.push(next);
			}
			else
			{
				if(map[x][y] >= 'A' && map[x][y] <= 'Z')
				{
					if(num[map[x][y] - 'A'] == 0 && door[map[x][y] - 'A'] == true) //所有的钥匙都找到
					{
						next.x = x; next.y = y; next.status = status;
						q.push(next);
						vis[x][y][status] = true;
						map[x][y] = '.';
					}
				}
				else	//该位置是钥匙
				{
					num[map[x][y] - 'a']--;
					next.x = x; next.y = y;
					if(num[map[x][y] - 'a'] == 0) //钥匙都找到了
					{
						status = status | (1<<(map[x][y] - 'a'));
					}
					next.status = status;
					q.push(next);
					vis[x][y][status] = true;
					map[x][y] = '.';
				}
			}
		}
	}
	return false;
}

int main()
{
	while(cin>>m>>n && m + n)
	{
		for(int i = 0; i < m; i++)
		{
			getchar();
			scanf("%s",map[i]);
		}
		memset(vis,false,sizeof(vis));
		memset(door,false,sizeof(door));
		memset(num,0,sizeof(num));
		for(int i = 0; i < m; i++)
			for(int j = 0; j < n; j++)
			{
				if(map[i][j] == 'S')
					sx = i, sy = j;
				else if(map[i][j] == 'G')
					ex = i, ey = j;
				else if(map[i][j] >= 'a' && map[i][j] <= 'z')
				{
					num[map[i][j] - 'a']++;
					door[map[i][j] - 'a'] = true;
				}
			}
		if(bfs()) cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
	}
	return 0;
}


你可能感兴趣的:(搜索)