HDU 1272 小希的迷宫

Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。 

 

Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。 
整个文件以两个-1结尾。 
 

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。 
 

Sample Input

     
     
     
     
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output

     
     
     
     
Yes Yes

No

这道题需要用到并查集,对于所有的边,2个端点仅能加入集合一次,所以如果一条边的2个顶点在遍历之前就加入集合的话,就表明有第二条路,也就是输出no。只输入"0 0 "的时候,条件符合,需要输出yes。接着需要判断该图是否是连通图,只需要边的数目等于顶点数-1即可。

#include <iostream>
#include <set>
#include <vector>
using namespace std;
int f[120000];
struct coord {
	int a, b;
};
int research(int a)
{
	if (f[a] == a)
		return a;
	else
		return f[a] = research(f[a]);
}
void getin(int a, int b)
{
	int t1 = research(a);
	int t2 = research(b);
	if (t1 != t2)
		f[t1] = t2;
}
int main()
{
	while (true)
	{
		coord k;
		int i = 0;
		bool flag = false;
		set<int> s;
		vector<coord> n;
		while (true)
		{
			cin >> k.a >> k.b;
			if (k.a == 0 && k.b == 0 || k.a == -1 && k.b == -1)
				break;
			n.push_back(k);
			s.insert(k.a);
			s.insert(k.b);
		}
		if (k.a == -1 && k.b == -1)
			break;
		if (n.size() == 0)
		{
			cout << "Yes" << endl;
			continue;
		}
		for (set<int>::iterator its = s.begin(); its != s.end(); its++)
		{
			f[*its] = *its;
			//cout << f[*its] << endl;
		}
		for (vector<coord>::iterator it = n.begin(); it != n.end(); it++)
		{
			if (research(it->a) != research(it->b))
			{
				getin(it->a, it->b);
				i++;
			}
			else
				flag = true;
		}
		//for (set<int>::iterator its = s.begin(); its != s.end(); its++)
			//cout << f[*its] << endl;
		if (i != s.size() - 1)
			flag = true;
		if (flag)
			cout << "No" << endl;
		else
			cout << "Yes" << endl;
	}
}

你可能感兴趣的:(HDU,并查集)