HDU 1060:Leftmost Digit【数学】

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15834    Accepted Submission(s): 6177


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
   
   
   
   
2 3 4
 

Sample Output
   
   
   
   
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
思路:
把num*num的值记作:num*num=a*10^n,其中1<a<10;
那么,通过两边取对数的方法得到num*log10(1.0*num)=log10(a)+n,这时0<log10(a)<1;
令x=n+log10(a),得到log10(a)=x-n;所以a=10^(x-n);
n为整数部分,log10(a)为小数部分,由x=n+log10(a),可知(int)x=n;
最终a=10^(x-n)=10^(x-(int)x)!
AC-code:
#include<cstdio>
#include<cmath>
int main()
{
	long long n;
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lld",&n);
		double x=n*log10(n*1.0);
		double a=x-(long long)x;
		int ans=pow(10.0,a);
		printf("%d\n",ans);
	}
 } 


你可能感兴趣的:(HDU 1060:Leftmost Digit【数学】)