BNU10782被诅咒的代码

被诅咒的代码

Time Limit: 1000ms
Memory Limit: 65536KB
64-bit integer IO format:  %lld      Java class name:  Main
Prev  Submit  Status  Statistics  Discuss  Next
Font Size:  +   -
Type:    None Graph Theory      2-SAT     Articulation/Bridge/Biconnected Component      Cycles/Topological Sorting/Strongly Connected Component      Shortest Path          Bellman Ford         Dijkstra/Floyd Warshall      Euler Trail/Circuit      Heavy-Light Decomposition      Minimum Spanning Tree      Stable Marriage Problem      Trees      Directed Minimum Spanning Tree      Flow/Matching         Graph Matching              Bipartite Matching              Hopcroft–Karp Bipartite Matching              Weighted Bipartite Matching/Hungarian Algorithm          Flow              Max Flow/Min Cut              Min Cost Max Flow  DFS-like     Backtracking with Pruning/Branch and Bound      Basic Recursion      IDA* Search     Parsing/Grammar      Breadth First Search/Depth First Search      Advanced Search Techniques          Binary Search/Bisection          Ternary Search  Geometry      Basic Geometry     Computational Geometry      Convex Hull      Pick's Theorem Game Theory      Green Hackenbush/Colon Principle/Fusion Principle      Nim      Sprague-Grundy Number  Matrix     Gaussian Elimination      Matrix Exponentiation  Data Structures      Basic Data Structures      Binary Indexed Tree      Binary Search Tree      Hashing     Orthogonal Range Search      Range Minimum Query/Lowest Common Ancestor      Segment Tree/Interval Tree      Trie Tree      Sorting     Disjoint Set  String      Aho Corasick     Knuth-Morris-Pratt      Suffix Array/Suffix Tree  Math      Basic Math     Big Integer Arithmetic      Number Theory          Chinese Remainder Theorem          Extended Euclid          Inclusion/Exclusion          Modular Arithmetic      Combinatorics         Group Theory/Burnside's lemma          Counting      Probability/Expected Value  Others     Tricky      Hardest     Unusual      Brute Force      Implementation     Constructive Algorithms      Two Pointer      Bitmask     Beginner      Discrete Logarithm/Shank's Baby-step Giant-step Algorithm      Greedy      Divide and Conquer  Dynamic Programming                      Tag it!
程序猿是一种近几十年来出现的新物种,是工业革命的产物。英文(Programmer Monkey)是一种非常特殊的、可以从事程序开发、维护的动物。一般分为程序设计猿和程序编码猿,但两者的界限并不非常清楚,都可以进行开发、维护工作,特别是在中国,而且最重要的一点,二者都是一种非常悲剧的存在。
最新的研究显示,程序猿有一大特点:易猝死。最近经常有某只程序猿猝死的消息直接占满题目作者人人首页的情况出现……
有一天,一只程序猿写了如下一段代码:
然后,突了个然!他就猝死了- -||
现在他剩下的工作被交给了你,请你写一个代码,能输出与这段代码相同的结果。(由于原先的代码遭到了程序猿的诅咒,直接提交他的代码或只是对他的代码进行小的改动是无法通过的……)

Input

第一行为一个整数T(T<=100)表示数据组数,接下来的T行每行一个整数n(n<10 9)。

Output

对于每组数据,输出一个数表示原先代码输出的结果。

Sample Input

3
1
2
3

Sample Output

1
3
6

Source

2011年北京师范大学新生程序设计竞赛

Author

思路:题意是求每个数的数位之和 正常做法必定超时 所以我们要找规律 ~
#include<stdio.h>
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int k;
        long long n;
        scanf("%lld",&n);
        k=n%9;
        n-=k;
        long long  sum;
        sum=n/9*45;//1~9的数位和为45
        for(int i=1;i<=k;i++)
            sum+=i;
        printf("%lld\n",sum%10000);
    }
    return 0;
}

你可能感兴趣的:(数学,BNU)