hdoj 4336 card collector(状态压缩dp求数学期望)

Card Collector


Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award. 

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks. 

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

Sample Input
   
   
   
   
1 0.1 2 0.1 0.4
 

Sample Output
   
   
   
   
10.000 10.500
 

Source
2012 Multi-University Training Contest 4

转自http://www.cnblogs.com/zhj5chengfeng/archive/2013/03/02/2939601.html
由于卡片最多只有 20 种,使用状态压缩,用 0 表示这种卡片没有收集到, 1 表示这种卡片收集到了

令:f[s] 表示已经集齐的卡片种类的状态的情况下,收集完所有卡片需要买东西次数的期望

买一次东西,包装袋中可能:

        1. 没有卡片

        2. 卡片是已经收集到的

        3. 卡片是没有收集到的

于是有:

        f[s] = 1 + ((1-segma{ p[i] })f[s]) + (segma{ p[j]*f[s] }) + (segma{ p[k]*f[s|(1<<k)] })

        其中:    i=0,2,...,n-1

                      j=第 j 种卡片已经收集到了,即 s 从右往左数第 j 位是 1:s&(1<<j)!=0

                      k=第 k 种卡片没有收集到,即 s 从右往左数第 k 位是 0:s&(1<<k)==0

移项可得:

        segma{ p[i] }f[s] = 1 + segma{ p[i]*f[s|(1<<i) },i=第i 种卡片没有收集到

目标状态是:f[0]

#include<cstdio>
using namespace std;
double f[1<<20],p[20];
int main()
{
    int n,i,s,N;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%lf",&p[i]);
            N=(1<<n)-1;
        f[N]=0;
        for(s=N-1;s>=0;s--)
        {
            double temp=0;
            f[s]=1;
            for(i=0;i<n;i++)
            {
                if(s&(1<<i))
                    continue;
                f[s]+=f[s|(1<<i)]*p[i];
                temp+=p[i];
            }
            f[s]/=temp;
        }
        printf("%lf\n",f[0]);
    }
    return 0;
}



你可能感兴趣的:(hdoj 4336 card collector(状态压缩dp求数学期望))