POJ 2407 Relatives 欧拉函数

http://poj.org/problem?id=2407

 

Relatives
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6610   Accepted: 2992

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4
在数论,对正整数n,欧拉函数是少于或等于n的数中与n互质的数的数目。此函数以其首名研究者欧拉命名,
它又称为Euler's totient function、φ函数、欧拉商数等。 例如φ(8)=4,因为1,3,5,7均和8互质。
 从欧拉函数引伸出来在环论方面的事实和拉格朗日定理构成了欧拉定理的证明。
/* Author : yan
 * Question : POJ 2407 Relatives
 * Date && Time : Saturday, January 29 2011 02:11 PM
 * Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
unsigned euler(unsigned x)
{// 就是公式
    unsigned i, res=x,tmp;
    tmp= (int)sqrt(x * 1.0) + 1;
    for (i = 2; i <tmp; i++)
        if(x%i==0)
        {
            res = res / i * (i - 1);
            while (x % i == 0) x /= i; // 保证i一定是素数
        }
        if (x > 1) res = res / x * (x - 1);
	return res;
}

int main()
{
	//freopen("input","r",stdin);
	int in;
	while(scanf("%d",&in) && in)
	{
		printf("%d/n",euler(in));
	}
	return 0;
}
 

 

你可能感兴趣的:(POJ 2407 Relatives 欧拉函数)