HZNU-1028: 多项式合并(map实现)

1028: STL Practice —— 【map (3)】

                                时间限制: 1 Sec  内存限制: 32 MB

题目描述:

给出一个多项式,例如:-10x^7 + 5x^3 + 4x^3 + x^2 + 2x^-1 只含有一个未知数,你需要合并同类项,并输出结果。

输入

第一行输入一个T,有T组测试样例
第二行输入一个c(10的6次方之内);
下面有c行,每行两个数据,第一个数据n(-100 < n < 1000000)代表系数,第二个数据m(在INT范围内)代表指数。

输出

输出合并同类项之后的结果(按照正常的手写格式输出),按指数从大到小输出。

样例输入
1
8
2 3
-1 4
3 3
2 4
3 -9
-3 -9
3 2
7 0

样例输出
x^4+5x^3+3x^2+7

题目思路:多项式求和,用map来存指数,系数。考虑指数为0和1的情况,系数为0,1,-1的情况。

题目链接:HZNU 1028

以下是代码:

#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;
map <int,int> mp;
int main(){
    int t;
    cin >> t;
    while(t--)
    {
        int c;
        cin >> c;
        mp.clear();
        for (int i = 0;i < c; i++)
        {
            int n;
            int m;
            cin >> n >> m;
            mp[m] += n;
        }
        map <int,int> :: reverse_iterator it;
        int flag = 0;
        for (it = mp.rbegin(); it != mp.rend();++it)
        {
            if (mp.size() == 1 && (*it).second == 0)
                cout << 0;
            if ((*it).second == 0)
                continue;
            if ((*it).second > 0 && flag)
                cout << "+";
            if ((*it).second != 1 && (*it).second != -1)
                cout << (*it).second;
            if ((*it).second == -1)
                cout << "-";
            if ((*it).first != 0 && (*it).first != 1)
                cout << "x^" << (*it).first;
            if ((*it).first == 1)
                cout << "x";
            flag = 1;
        }
        cout << endl;
    }
    return 0;
}

你可能感兴趣的:(map,STL,多项式求和)