ZOJ-3776-Pokemon Master【11th浙江省赛】

ZOJ-3776-Pokemon Master

                    Time Limit: 2 Seconds      Memory Limit: 65536 KB

Calem and Serena are pokemon masters. One day they decided to have a pokemon battle practice before Pokemon World Championships. Each of them has some pokemons in each’s team. To make the battle more interesting, they decided to use a special rule to determine the winner: the team with heavier total weight will win the battle!

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 6), which describes that Calem has N pokemons and Serena has M pokemons.

The second line contains N integers indicating the weight of Calem’s pokemons. The third line contains M integers indicating the weight of Serena’s pokemons. All pokemons’ weight are in the range of [1, 2094] pounds.

Output

For each test case, output “Calem” if Calem’s team will win the battle, or “Serena” if Serena’s team will win. If the two team have the same total weight, output “Draw” instead.

Sample Input
1
6 6
13 220 199 188 269 1014
101 176 130 220 881 396

Sample Output
Serena

题目链接:ZOJ-3776

题目思路:水题

以下是代码:

#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;

int main(){
    int t;
    cin >> t;
    while(t--)
    {
        int n,m;
        cin >> n >> m;
        int sum1 = 0,sum2 = 0,w;
        for (int i = 0; i < n; i++)
        {
            cin >> w; 
            sum1 += w;
        }
        for (int i = 0; i < m; i++)
        {
            cin >> w;
            sum2 += w;
        }
        if (sum1 > sum2)    cout << "Calem\n";
        else if (sum1 < sum2)   cout << "Serena\n";
        else    cout << "Draw\n";
    } 
    return 0;
}

你可能感兴趣的:(ZOJ,3776)