HDU 1548 A strange lift(最短路问题Dijkstra实现)

Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
   
   
   
   
5 1 5 3 3 1 2 5 0
 

Sample Output
   
   
   
   
3
 

//Must so
#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>
#include<ctype.h>
#include<queue>
#include<vector>
#include<set>
#include<cstdio>
#include<cmath>
#define mem(a,x) memset(a,x,sizeof(a))
#define inf 1<<29
#define NN 1000006
using namespace std;
const double PI = acos(-1.0);
typedef long long LL;

/**********************************************************************
题意:
一个电梯,每层都有一个数字,
当你在i层时,可以选向上走Ki层,或者向下走Ki层
当然,你最高只能到达第n层,最低只能到达第1层
问从A到B,至少走多少次
第一眼觉得是BFS,仔细一想,其实把图构造出来就简单了
每次输入都给出了2条路,从当前位置向上走Ki或向下走Ki
于是map就出来了,然后就是最短路的题了,边权都是1表示步数
**********************************************************************/
int n,s,t;//n个点,起点s,终点t
int d[202];
int mp[202][202];
bool vis[202];
void init()
{
    for (int i = 0;i <= n;i++)
    {
        for (int j = 0;j <= n;j++)
        {
            mp[i][j] = inf;
        }
        mp[i][i] = 0;
        d[i] = inf;
    }
}
void Dijk()
{
    mem(vis,0);
    d[s] = 0;
    for (int i = 1;i <= n;i++)
    {
        int mn = inf,pos;
        for (int j = 1;j <= n;j++)
        {
            if (d[j] < mn&&vis[j] == 0)
            {
                mn = d[j];
                pos = j;
            }
        }
        vis[pos] = 1;
        for (int j = 1;j <= n;j++)
        {
            d[j] = min(d[j],d[pos]+mp[pos][j]);
        }
    }
}
int main()
{
    while (cin>>n)
    {
        if (!n) break;
        cin>>s>>t;
        init();
        for (int i = 1,k;i <= n;i++)
        {
            scanf("%d",&k);
            if (i+k <= n) mp[i][i+k] = 1;//不能超出范围
            if (i-k >= 1) mp[i][i-k] = 1;
        }
        Dijk();
        if (d[t] == inf) puts("-1");
        else printf("%d\n",d[t]);
    }
    return 0;
}

你可能感兴趣的:(dijkstra,杭电)