POJ 3279-Fliptile(母牛翻方格-开关问题)

Fliptile
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6893   Accepted: 2616

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source

USACO 2007 Open Silver


题目意思:

农夫约翰知道聪明的牛产奶多。于是为了提高牛的智商他准备了如下游戏。有一个M×N 的格子,每个格子可以翻转正反面,它们一面是黑色,另一面是白色。黑色的格子翻转后就是白色,白色的格子翻转过来则是黑色。游戏要做的就是把所有的格子都翻转成白色。不过因为牛蹄很大,所以每次翻转一个格子时,与它上下左右相邻接的格子也会被翻转。因为翻格子太麻烦了,所以牛都想通过尽可能少的次数把所有格子都翻成白色。现在给定了每个格子的颜色,请求出用最小步数完成时每个格子翻转的次数。最小步数的解有多个时,输出字典序最小的一组。解不存在的话,则输出IMPOSSIBLE。


解题思路:

首先,同一个格子翻转两次的话就会恢复原状,所以多次翻转是多余的。此外,翻转的格子的集合相同的话,其次序是无关紧要的。因此,总共有2NM种翻转的方法。不过这个解空间太大了,我们需要想出更有效的办法。让我们再回顾一下前面的问题。在那道题中,让最左端的牛反转的方法只有1种,于是用直接判断的方法确定就可以了。同样的方法在这里还行得通吗?不妨先看看最左上角的格子。在这里,除了翻转(1,1)之外,翻转(1,2)和(2,1)也可以把这个格子翻转,所以像之前那样直接确定的办法行不通。于是不妨先指定好最上面一行的翻转方法。此时能够翻转(1,1)的只剩下(2,1)了,所以可以直接判断(2,1)是否需要翻转。类似地(2,1)~(2,N)都能这样判断,如此反复下去就可以确定所有格子的翻转方法。最后(M,1)~(M,N)如果并非全为白色,就意味着不存在可行的操作方法。像这样,先确定第一行的翻转方式,然后可以很容易判断这样是否存在解以及解的最小步数是多
少,这样将第一行的所有翻转方式都尝试一次就能求出整个问题的最小步数。这个算法中最上面一行的翻转方式共有2N种,复杂度为O(MN2N)。



#include<iostream>
#include<cstring>
#include<cstdio>
#include<malloc.h>
using namespace std;

const int MAXN=16;
const int inf=0x3f3f3f3f;
const int dx[5]= {-1,0,0,0,1};//邻接格子的方向
const int dy[5]= {0,-1,0,1,0};

int M,N;//长宽
int tile[MAXN][MAXN];//初始状态
int flip[MAXN][MAXN];//中间结果翻转次数
int opt[MAXN][MAXN];//最优解

int get(int x,int y)//查询x,y的颜色
{
    int c=tile[x][y];
    for(int i=0; i<5; ++i)
    {
        int x2=x+dx[i];
        int y2=y+dy[i];
        if(x2>=0&&x2<M&&y2>=0&&y2<N)
            c+=flip[x2][y2];
    }
    return c&1;//奇数为1,偶数为0
}
//求出第一行确定情况下的最小操作次数
//不存在解的话输出-1
int calc()
{
    //求出第2行开始的翻转方法
    for(int i=1; i<M; ++i)
        for(int j=0; j<N; ++j)
            if(get(i-1,j)!=0)//0白1黑,是黑色则翻转
                flip[i][j]=1;
    //判断最后一行是否全白
    for(int j=0; j<N; ++j)
        if(get(M-1,j)!=0)
            return -1;
    int res=0;//统计翻转次数
    for(int i=0; i<M; ++i)
        for(int j=0; j<N; ++j)
            res+=flip[i][j];
    return res;
}
void solve()
{
    int res=-1;
    for(int i=0; i< (1<<N); ++i) //按字典序尝试第一行的所有可能性
    {
        memset(flip,0,sizeof(flip));
        for(int j=0; j<N; j++)
            flip[0][N-j-1] = i>>j&1;
        int num=calc();//计算反转次数
        if(num>=0&&(num<res||res<0))
        {
            res=num;
            memcpy(opt,flip,sizeof(flip));//更新最优解
        }
    }
    if(res<0) puts("IMPOSSIBLE");
    else
        for(int i=0; i<M; ++i)
            for(int j=0; j<N; ++j)
                printf("%d%c",opt[i][j],j+1==N?'\n':' ');
}
int main()
{
    while(cin>>M>>N)
    {
        for(int i=0; i<M; ++i)
            for(int j=0; j<N; ++j)
                scanf("%d",&tile[i][j]);
        solve();
    }
    return 0;
}


你可能感兴趣的:(C++,poj,poj,开关问题,Fliptile,3279)