hdoj 1856 More is better(并查集)

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 18725    Accepted Submission(s): 6878


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
   
   
   
   
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
   
   
   
   
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 


数组存节点数,在进行比较,输出最大的节点数,但是 提上给出的数据 1000W  太大可能超内存,用  n (0 ≤ n ≤ 100 000) 做限制。
#include<cstdio>
#include <iostream>
#include<algorithm>
#include <cstdlib>
#include <cstring>
#define N 100000+10
using namespace std;
int per[N];
int s[N];
int sum;

int find(int r)
{
	/*压缩路径   提高速度   要不然超时。*/ 
	int a=r;
	int b;
	while(a!=per[a])
		a=per[a];
	per[r]=a;
	while(r!= a )
	{
		b=per[r];
		per[r]=a;
		r=b;
	}
	return r;
}

void join(int x,int y)
{
	int a=find(x);
	int b=find(y);
	if(a!=b)
	{
		per[a]=b;
		s[b]+=s[a];
		sum = max(sum,s[b]);
	}
}
int main()
{
	int t,a,b;
	while(scanf("%d",&t) !=EOF )
	{
		if(t==0)
		{
			printf("1\n");
			continue;
		}
		
		sum = 0;
		for(int i=1;i<=100010;i++ )
		{
			per[i]=i;
			s[i]=1;
		}
		while(t--)
		{
			scanf("%d %d",&a,&b);
			join(a,b);
		}
		printf("%d\n",sum);
	}
	return 0;
}


你可能感兴趣的:(并查集)