HDU1728:逃离迷宫(BFS)

Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2  (1 ≤ k ≤ 10, 1 ≤ x 1, x 2  ≤ n, 1 ≤ y 1, y 2  ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。
 

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 

Sample Input
   
   
   
   
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
 

Sample Output
   
   
   
   
no yes
 

 

这道题我必须严重的吐槽下
之前是用DFS做的,然后果断就超时了

再用BFS做,但是无论如何样例都过不了,我就郁闷了

找了两个多小时,最后看人家代码才惊讶的发现,原来题目中的X是代表列,Y是代表行!

我擦!

以后得把题目看清楚了T_T

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;

int n,m,x1,y1,x2,y2,k;
int map[105][105],ans;
int to[4][2] = {1,0,-1,0,0,1,0,-1};

struct node
{
    int x,y,step;
};

int check(int x,int y)
{
    if(x<0 || y<0 || x>=n || y>=m)
        return -1;
    return map[x][y];
}

int bfs()
{
    int i,flag;
    queue<node> Q;
    node a,next;
    a.x = x1;
    a.y = y1;
    a.step = -1;
    map[a.x][a.y] = -1;
    Q.push(a);
    while(!Q.empty())
    {
        a = Q.front();
        Q.pop();
        if(a.step>k)
            return -1;
        if(a.x == x2 && a.y == y2)
            return 1;
        for(i = 0; i<4; i++)
        {
            next.x = a.x+to[i][0];
            next.y = a.y+to[i][1];
            flag = check(next.x,next.y);
            while(flag!=-1)
            {
                if(flag==0)
                {
                    next.step = map[next.x][next.y] = a.step+1;
                    Q.push(next);
                }
                next.x+=to[i][0];
                next.y+=to[i][1];
                flag = check(next.x,next.y);
            }
        }
    }
    return -1;
}

int main()
{
    int t;
    char s[105];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        int i,j;
        for(i = 0; i<n; i++)
        {
            scanf("%s",s);
            for(j = 0; s[j]; j++)
            {
                if(s[j]=='.')
                    map[i][j]=0;
                else if(s[j]=='*')
                    map[i][j]=-1;
            }
        }
        scanf("%d%d%d%d%d",&k,&y1,&x1,&y2,&x2);
        x1--;
        x2--;
        y1--;
        y2--;
        ans = bfs();
        if(ans==-1)
            printf("no\n");
        else
            printf("yes\n");
    }

    return 0;
}


 

你可能感兴趣的:(ACM,HDU,解题报告,bfs)