Pet
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1777 Accepted Submission(s): 856
Problem Description
One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.
Input
The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.
Output
For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
Sample Input
1 10 2 0 1 0 2 0 3 1 4 1 5 2 6 3 7 4 8 6 9
Sample Output
搜索做法真心不会啊。。。。并查集来吧。
题意:图中有n个点,编号为0—n-1。给出n-1行数据,每行有两个整数x,y,表示点x与y之间有路径联通,并且路径长度都为单位长度。判断到零点路径长度大于d的有多少个。
题解:用并查集处理比较简单,直接按照输入的点与点的联通关系建图,数出到0点距离超过d的点即可。
代码如下:
#include<cstdio>
int set[100010];
int find(int x)
{
int r=x;
while(set[r]!=r)
r=set[r];
return r;
}
int main()
{
int n,i,d,sum,t,a,b,cnt;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&d);
for(i=0;i<n;i++)
set[i]=i;
for(i=1;i<n;i++)
{
scanf("%d%d",&a,&b);
set[b]=a;//不查找其根节点直接合并,保持树的原型
}
sum=0;
for(i=0;i<n;i++)
{
cnt=0;
int x=i;
if(find(x)==0)//若根节点为零,且该点到根节点的路径大于d则sum++
{
while(x!=set[x])
{
x=set[x];
cnt++;
}
}
if(cnt>d)
sum++;
}
printf("%d\n",sum);
}
return 0;
}