poj2115 C Looooops (欧几里德)

C Looooops
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20515   Accepted: 5531

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

Source

CTU Open 2004

题意:求for (int i=A; i!=B; i+=C) i%=2^k;循环了多少次。
分析:由题可以看出循环终止的时候i==B;此时有(A+Cx)%2^k==B;即:C*x - 2^k*y==B-A。标准欧几里德。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

void exgcd(ll a, ll b, ll &d, ll &x, ll &y)
{
    if(!b){d=a; x=1; y=0;}
    else
    {
        exgcd(b, a%b, d, y, x);
        y-=x*(a/b);
    }
}

int main ()
{
    ll A,B,C,k;
    while (scanf("%lld%lld%lld%lld",&A,&B,&C,&k),(A+B+C+k))
    {
        ll a,b,d,x,y;
        ll c=B-A;
        if (!c) {cout<<"0"<<endl; continue;}
        a=C; b=(ll)1<<k;//位运算2^k
        exgcd(a, b, d, x, y);
        if (c%d) {cout<<"FOREVER"<<endl; continue;}
        ll dm=b/d;
        x = ((x*c/d)%dm+dm)%dm;
        cout<<x<<endl;
    }
    return 0;
}


你可能感兴趣的:(数论,扩展欧几里德)