UVA 10806 - Dijkstra, Dijkstra.(费用流)

Problem ?
Dijkstra, Dijkstra.
Time Limit: 10 seconds

Dexter: "You don't understand. I can't walk...
they've tied my shoelaces together."

Topper Harley: "A knot. Bastards!"

Jim Abrahams and Pat Proft,
"Hot Shots! Part Deux."

You are a political prisoner in jail. Things are looking grim, but fortunately, your jailmate has come up with an escape plan. He has found a way for both of you to get out of the cell and run through the city to the train station, where you will leave the country. Your friend will escape first and run along the streets of the city to the train station. He will then call you from there on your cellphone (which somebody smuggled in to you inside a cake), and you will start to run to the same train station. When you meet your friend there, you will both board a train and be on your way to freedom.

Your friend will be running along the streets during the day, wearing his jail clothes, so people will notice. This is why you can not follow any of the same streets that your friend follows - the authorities may be waiting for you there. You have to pick a completely different path (although you may run across the same intersections as your friend).

What is the earliest time at which you and your friend can board a train?

Problem, in short
Given a weighed, undirected graph, find the shortest path from S to T and back without using the same edge twice.

Input
The input will contain several test cases. Each test case will begin with an integer n (2<=n<=100) - the number of nodes (intersections). The jail is at node number 1, and the train station is at node number n. The next line will contain an integer m - the number of streets. The next m lines will describe the m streets. Each line will contain 3 integers - the two nodes connected by the street and the time it takes to run the length of the street (in seconds). No street will be longer than 1000 or shorter than 1. Each street will connect two different nodes. No pair of nodes will be directly connected by more than one street. The last test case will be followed by a line containing zero.

Output
For each test case, output a single integer on a line by itself - the number of seconds you and your friend need between the time he leaves the jail cell and the time both of you board the train. (Assume that you do not need to wait for the train - they leave every second.) If there is no solution, print "Back to jail".

Sample Input Sample Output
2
1
1 2 999
3
3
1 3 10
2 1 20
3 2 50
9
12
1 2 10
1 3 10
1 4 10
2 5 10
3 5 10
4 5 10
5 7 10
6 7 10
7 8 10
6 9 10
7 9 10
8 9 10
0
Back to jail
80
Back to jail

题意:找从1到n来回的最短路。每条边走一次

思路:最大流最小费用,建图,源点到1容量2费用0,n到汇点容量2,费用0,最后判断最大流如果为2则是可以到的,输出最小费用

代码:

#include <stdio.h>
#include <string.h>
#define INF 0x3f3f3f3f
#include <queue>
using namespace std;
const int N = 105, M = 50005;

int n, m, A, B, D, K, E, first[N], next[M], u[M], v[M], pe[N], pv[N], a[N], f[M], w[M], s, t, value, cost[M];
queue<int>q;

void add(int a, int b, int value, int time) {
	u[E] = a; v[E] = b; w[E] = value; cost[E] = time;
	next[E] = first[u[E]];
	first[u[E]] = E ++;
	u[E] = b; v[E] = a; w[E] = 0; cost[E] = -time;
	next[E] = first[u[E]];
	first[u[E]] = E ++;
}

void init() {
	scanf("%d", &m);
	E = s = 0, t = n + 1;
	memset(first, -1, sizeof(first));
	for (int i = 0; i < m; i ++) {
		scanf("%d%d%d", &A, &B, &value);
		add(A, B, 1, value);
		add(B, A, 1, value);
	}
	add(s, 1, 2, 0);
	add(n, t, 2, 0);
}

void solve() {
	init();
	bool vis[N];
	int d[N], C = 0;
	int F = 0;
	memset(f, 0, sizeof(f));
	while(1) {
		memset(d, INF, sizeof(d));
		d[s] = 0;
		memset(vis, 0, sizeof(vis));
		q.push(s);
		while(!q.empty()) {
			int u = q.front(); q.pop();
			vis[u] = 0;
			for (int e = first[u]; e != -1; e = next[e]) {
				if (w[e] > f[e] && d[v[e]] > d[u] + cost[e]) {
					d[v[e]] = d[u] + cost[e];
					pv[v[e]] = u; pe[v[e]] = e;
					if (!vis[v[e]]) {
						vis[v[e]] = 1;
						q.push(v[e]);
					}
				}
			}
		}
		if (d[t] == INF) break;
		int a = INF;
		for (int v = t; v != s; v = pv[v])
			a = min(a, w[pe[v]] - f[pe[v]]);
		for (int v = t; v != s; v = pv[v]) {
			f[pe[v]] += a;
			f[pe[v]^1] -= a;
		}
		C += d[t] * a;
		F += a;
	}
	if (F < 2) printf("Back to jail\n");
	else printf("%d\n", C);
}

int main() {
	while (~scanf("%d", &n) && n) {
		solve();
	}
	return 0;
}


你可能感兴趣的:(UVA 10806 - Dijkstra, Dijkstra.(费用流))