Arbitrage
Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar
3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar
0
Sample Output
很明显是最短路问题,但是 不能硬套模板,应对模板进行合题意的修改。
#include <iostream>
#include <map>
#include <memory.h>
#define NUM 35
using namespace std;
int n;
double g[NUM][NUM];
double dis[NUM][NUM];
map<string,int> mp;
void Floyd()
{
//这里的初始化实际上就是将g数组赋值给dis数组,其实也可以直接利用g数组进行计算
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
dis[i][j]=g[i][j];
}
}
for(int k=0;k<n;k++)
{
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
if(dis[i][j]<dis[i][k]*dis[k][j])
dis[i][j]=dis[i][k]*dis[k][j];
}
}
}
}
int main()
{
int p=1;
while(cin>>n&&n!=0)
{
int m;
int flag=0;
double t;
char ch[55],s[55],e[55];
mp.clear();
memset(g,0,sizeof(g));//要格外注意这里的初始化,由于本题目是计算乘法,所以不能使用普通最短路无穷大的初始化方法
for(int i=0;i<n;i++)
{
cin>>ch;
mp[ch]=i;
}
cin>>m;
for(int i=0;i<m;i++)
{
cin>>s>>t>>e;
g[mp[s]][mp[e]]=t;
}
Floyd();
for(int i=0;i<n;i++)
{
if(dis[i][i]>1.0)
flag=1;
}
cout<<"Case "<<p<<": ";
if(flag==1)
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
p++;
}
return 0;
}