HDU 2602:Bone Collector【01背包】

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 40266    Accepted Submission(s): 16731


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
HDU 2602:Bone Collector【01背包】_第1张图片
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14
 

AC-code:

#include<cstdio>
#include<cstring>
#define max(a,b) a>b?a:b
int f[1005],c[1005],val[1005];
int main()
{
	int t,n,v,i,j;
	scanf("%d",&t);
	while(t--)
	{
		memset(f,0,sizeof(f));
		scanf("%d%d",&n,&v);
		for(i=0;i<n;i++)
			scanf("%d",&val[i]);
		for(i=0;i<n;i++)
			scanf("%d",&c[i]);
		for(i=0;i<n;i++)
			for(j=v;j>=c[i];j--)
				f[j]=max(f[j],f[j-c[i]]+val[i]);
		printf("%d\n",f[v]);
	}
	return 0;
}



 

你可能感兴趣的:(动态规划,HDU,背包)