HDU-1087-Super Jumping! Jumping! Jumping!

F - Super Jumping! Jumping! Jumping!
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

HDU 1087
Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the maximum according to rules, and one line one case.

Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output
4
10
3

题意:多组输入,每行第一个N,代表接下来有N个数字;
输出这N个数字中最大的上升子序列的和。

很水的一道动态规划,跟求最大上升子序列长度的思想一样。
状态转移方程:dp[i]=max(dp[i],dp[j]+num[i])
只要理解了题意,又做过最大上升子序列长度的题,这题应该不是问题

代码

#include<iostream>
#include<algorithm>
#include<math.h>
#include<string>
#include<string.h>
#include<stdio.h>
#include<queue>
using namespace std;
//最大上升子序列的和
int num[1005];//存储数字
int dp[1005];//前i位最大上升子序列的和
int N;//数字个数
int main()
{
    while(~scanf("%d",&N)&&N)
    {
        for(int i=0; i<N; i++)
            scanf("%d",&num[i]);
        memset(dp,0,sizeof(dp));
        int max_num;
        dp[0]=max_num=num[0];
        for(int i=1; i<N; i++)
        {
            dp[i]=num[i];
            for(int j=0; j<i; j++)
            {
                if(num[i]>num[j])
                {
                    if(dp[i]<dp[j]+num[i])
                        dp[i]=dp[j]+num[i];
                }
            }
            if(dp[i]>max_num)
                max_num=dp[i];
        }
        printf("%d\n",max_num);
    }
    return 0;
}

你可能感兴趣的:(动态规划)