nyoj 211 (Floyd算法求传递闭包)

Cow Contest

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

输入
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

There are multi test cases.The input is terminated by two zeros.The number of test cases is no more than 20.
输出
For every case:
* Line 1: A single integer representing the number of cows whose ranks can be determined
样例输入
5 5
4 3
4 2
3 2
1 2
2 5
0 0
样例输出

2


解题思路:这里用到了Floyd算法,找到了每个点与其他点之间的关系,就能够确定该点与其他点关系的个数,如果等于n-1就说明该点的顺序是确定的。。。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 110;
int n,m;
bool map[maxn][maxn];

int main()
{	
	while(scanf("%d%d",&n,&m)!=EOF && m + n)
	{
		memset(map,false,sizeof(map));
		int a,b;
		for(int i = 1; i <= m; i++)
		{
			scanf("%d%d",&a,&b);
			map[a][b] = true;
		}
		for(int k = 1; k <= n; k++)
			for(int i = 1; i <= n; i++)
				for(int j = 1; j <= n; j++)
					if(map[i][k] && map[k][j])
						map[i][j] = true;
		int ans = 0, cnt = 0;
		for(int k = 1; k <= n; k++)
		{	
			cnt = 0;
			for(int i = 1; i <= n; i++)
			{
				if(i == k) continue;
				if(map[i][k]) cnt++;
				if(map[k][i]) cnt++;
			}
			if(cnt == n-1) ans++;
		}
		printf("%d\n",ans);
	}
	return 0;	
}

你可能感兴趣的:(图论)