二分图最大匹配

[POJ 3041] (http://poj.org/problem?id=3041)
题目描述:

Asteroids(小行星)
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17848 Accepted: 9716
Description

Bessie wants to navigate(驾驭,操纵) her spaceship through a dangerous asteroid(小行星) field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice(晶体) points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize(蒸发) all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly(节约的).Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate(消除) all of the asteroids.
Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
    Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.
    Sample Input

3 4
1 1
1 3
2 2
3 2
Sample Output

2
Hint

INPUT DETAILS:
The following diagram represents the data, where “X” is an asteroid and “.” is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
Source

USACO 2005 November Gold

言简意赅:
此题可抽象成二分图来做, 此题给出n(n个左节点),k(k组数据),和k组r和c,之后即可借助于匈牙利算法来求解二分图最大匹配的问题,由于数据较小,则可以直接使用矩阵来实现;
代码实现如下:

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;
const int MAX=510;
int uN;
int g[MAX][MAX];
int linker[MAX];
bool used[MAX];
bool dfs(int u)//深搜寻找增光路
{
    for(int v=1;v<=uN;v++)//编号从1开始
    {
        if(g[u][v]&&!used[v])
        {
            used[v]=true;
            if(linker[v]==-1 || dfs(linker[v]))
            {
                linker[v]=u;
                return true;
            }
        }
    }
    return false;
}

int hungary()//匈牙利算法计数
{
    int res=0;
    memset(linker,-1,sizeof(linker));
    for(int u=1; u<=uN; u++)//编号从1开始
    {
        memset(used,false,sizeof(used));
        if(dfs(u)) res++;
    }
    return res;
}

int main()
{
    int k,r,c;
    while(scanf("%d%d",&uN,&k)!=EOF)
    {
        memset(g,0,sizeof(g));//开始把g数组全初始化为0
        while(k--)
        {
            scanf("%d%d",&r,&c);
            g[r][c]=1;//若r和c之间有关联即将其记为1
        }
        printf("%d\n",hungary());
    }

    return 0;
}

你可能感兴趣的:(二分图最大匹配,匈牙利算法)