HDU 1059 Dividing

完全背包的优化版,之前很少接触完全背包,一直以为完全背包就是01背包前加一个while(amount–),如果amount特别大的话,就肯定会超时了,这道题就是,自己用以前的方法写了一遍,TLE,看别人博客原来要用二进制优化,假如同一件物品有10个的话,可以先放1个,再放1个价值质量为两倍的,再放一个价值质量为4倍的,因为10-1-2-4=3,所以最后再放一个质量价值为3倍的,
Dividing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22672 Accepted Submission(s): 6400

Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.

The last line of the input file will be “0 0 0 0 0 0”; do not process this line.

Output
For each colletcion, output Collection #k:'', where k is the number of the test case, and then eitherCan be divided.” or “Can’t be divided.”.

Output a blank line after each test case.

Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output
Collection #1:
Can’t be divided.

Collection #2:
Can be divided.

Source
Mid-Central European Regional Contest 1999
代码:

#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
int dp[120010],a[10],all;
void zerooneback(int value)
{
    int i;
    for(i=all; i>=value; i--)
        dp[i]=max(dp[i],dp[i-value]+value);
}
void multipleback(int value,int amount)
{
    int k=1;
    while(k<amount)
    {
        zerooneback(k*value);
        amount-=k;
        k*=2;
    }
    zerooneback(amount*value);
}
int main()
{
    int S=0;
    while(scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6])&&(a[1]||a[2]||a[3]||a[4]||a[5]||a[6]))
    {
        memset(dp,0,sizeof(dp));
        int i,j;
        all=0;
        for(i=1; i<=6; i++)
            all+=a[i]*i;
        if(all&1)
        {
            printf("Collection #%d:\nCan't be divided.\n\n",++S);
            continue;
        }
        all/=2;
        for(i=1; i<=6; i++)
            multipleback(i,a[i]);
        if(dp[all]==all)
            printf("Collection #%d:\nCan be divided.\n\n",++S);
        else
            printf("Collection #%d:\nCan't be divided.\n\n",++S);
    }
}

你可能感兴趣的:(动态规划,hdu日常小练)