hdu-1198-Farm Irrigation(并查集)

Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

hdu-1198-Farm Irrigation(并查集)_第1张图片
Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like

hdu-1198-Farm Irrigation(并查集)_第2张图片
Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A’ to ‘K’, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output

2
3

并查集的应用,判断每个点是不是与其右边和下边的连通,如果连通就合并。最后判断有多少个集合
代码如下:

#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <vector>
#include <algorithm>
#define N 55
const int mm = 1000000007;
using namespace std;
char map[N][N];
int n, m, father[2555];
bool left(char c)
{
    if (c == 'A' || c == 'C' || c == 'F' || c == 'G' || c == 'H' || c == 'I' || c == 'K') return true;
    return false;
}
bool right(char c)
{
    if (c == 'B' || c == 'D' || c == 'F' || c == 'G' || c == 'I' || c == 'J' || c == 'K')   return true;
    return false;
}
bool down(char c)
{
    if (c == 'C' || c == 'D' || c == 'E' || c == 'H' || c == 'I' || c == 'J'  || c == 'K')  return true;
    return false;
}
bool up(char c)
{
    if (c == 'A' || c == 'B' || c == 'E' || c == 'G' || c == 'H' || c == 'J' || c == 'K') return true;
    return false;
}
int find(int x)
{
    if (x != father[x])
        father[x] = find(father[x]);
    return father[x];
}
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int i, j, ans, a, b;
    while(cin >> n >> m)
    {
        if (n == -1 && m == -1) break;
        ans = 0;
        for (i = 0; i < n; i++)
            cin >> map[i];
        for (i = 0; i <= n*m; i++)
            father[i] = i;
        for (i = 0; i < n; i++)
        {
            for (j = 0; j < m; j++)
            {
                if (i + 1 < n)
                {
                    if (down(map[i][j]) && up(map[i+1][j]))
                    {
                        a = find(i*m+j);
                        b = find(i*m+m+j);
                        if (a != b) father[a] = b;
                    }
                }
                if (j + 1 < m)
                {
                    if (right(map[i][j]) && left(map[i][j+1]))
                    {
                        a = find(i*m+j);
                        b = find(i*m+j+1);
                        if (a != b) father[a] = b;
                    }
                }
            }
        }
        for (i = 0; i < n*m; i++)
            if (i == father[i]) ans++;
        if (ans)    cout << ans << endl;
        else    cout << 1 << endl;
    }
    return 0;
}

你可能感兴趣的:(hdu-1198-Farm Irrigation(并查集))