Monkey and Banana
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7559 Accepted Submission(s): 3896
Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
Source
University of Ulm Local Contest 1996
题意:有n种石块,每种无数块。给出n种石块的长、宽、高,要你堆叠起来,要求上面的石块面积完全被下面石块的 面积覆盖,求最高能叠多高。
一开始连题目都看不懂,后来知道题意后想了半天也没想出来,,情况比较多,没想到要怎样排序。。一天就这样过了啊。。后来参考其他人的思路懂了后就过了。。。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct Node
{
int len, wide, high;
}dis[100];
bool cmp(Node c, Node d)
{
if(c.len == d.len)
return c.wide > d.wide;
return c.len > d.len;
}
int main()
{
int n, i, j, t = 1, dp[1000];
while(~scanf("%d", &n), n)
{
int a, b, c;
for(i=1; i<=3*n; i+=3) //由于每种石块有无数个,故把一种石块的不同形态当做不同种类石块
{
scanf("%d%d%d", &a,&b,&c); //下面假设长的为长,短的为宽,这样可以避免一些情况
dis[i].len = max(a,b); dis[i].wide = min(a,b); dis[i].high = c;
dis[i+1].len = max(a,c); dis[i+1].wide = min(a,c); dis[i+1].high = b;
dis[i+2].len = max(b,c); dis[i+2].wide = min(b,c); dis[i+2].high = a;
}
// memset(dp, 0, sizeof(dp));
sort(dis+1,dis+3*n+1,cmp); //按长排序
int maxn = 0;
for(i=1; i<=3*n; i++)
{
dp[i] = dis[i].high;
for(j=i-1; j>=1; j--) //保证dp[j]算出来前dp[i]已算出
{
if(dis[j].len > dis[i].len && dis[j].wide > dis[i].wide) //满足长、宽递减
dp[i] = max(dp[i], dp[j]+dis[i].high); //看哪个状态加上前面的高度后能否大于目前状态
}
if(dp[i] > maxn) maxn = dp[i];
}
printf("Case %d: maximum height = %d\n", t++,maxn);
}
return 0;
}