杭电ACM1012

(1)题目大意:
Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.
This problem involves the efficient computation of integer roots of numbers.
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n th. power, for an integer k (this integer is what your program must find).
 

Input
The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10<sup>101</sup> and there exists an integer k, 1<=k<=10<sup>9</sup> such that k<sup>n</sup> = p.
 

Output
For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.
 

Sample Input
    
    
    
    
2 16 3 27 7 4357186184021382204544
 

Sample Output
    
    
    
    
4 3 1234
就是给出n和p,求出k,使得k^n=p,p的范围到10^101,用double类型就可以做。
(2)解题思路:
  用pow函数进行比较,如果pow(k,n)==p则输出k,由于要遍历的范围过大,所以采用二分法,节省时间。
(3)感想:
  略。
(4)代码:
#include<iostream>
#include<cmath>
using namespace std;
int main()
{


 double begin = 0, end = 1000000000;
 double n, p;
 while (cin >> n >> p)
 {
  begin = 0;
  end = 1000000000;
  while (begin<end)
  {
   double mid = (double)((begin + end) / 2);
   if (pow(mid, n) < p)
   {
    begin = mid;
   }
   else if (pow(mid, n) > p)
   {
    end = mid;
   }
   else if (pow(mid, n) == p)
   {
    cout << mid << endl;
    break;

   }

  }

 }

 return 0;

}

你可能感兴趣的:(ACM,杭电)