Play the Dice
http://acm.hdu.edu.cn/showproblem.php?pid=4586
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Special Judge
Problem Description
There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.
Input
Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a
i(0<=a
i<200)
The second line is an integer m (0<=m<=n), following with m integers b
i(1<=b
i<=n), which are the numbers of the special sides to get another more chance.
Output
Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.
Sample Input
6 1 2 3 4 5 6
0
4 0 0 0 0
1 3
Sample Output
题目大意:给定一个n面骰子,每一面的点数为a[i],取到每一面的概率都相等,其中m个面是有颜色的,若取到有颜色的面,则可再掷一次,直道掷出没有颜色的一面,求点数的期望?
第一次掷出的期望为:sum/n
有m/n的概率掷第二次,第二次掷出的期望为:sum/n*(m/n)
.
.
.
有(m/n)^x的概率掷出第x次,第x次掷出的期望为:sum/*(m/n)
则总期望为:sum/n*(1+m/n+…(m/n)^x)=sum/n*((1-(m/n)^x)/(1-(m/n)))
取极限后化简得:sum/(n-m)
需要注意的是:若n==m&&sum!=0时,期望为inf,若sum==0时,期望为0,其余可用上述公式
#include <cstdio>
using namespace std;
int n,m,a,sum;
int main() {
while(scanf("%d",&n)!=EOF){
sum=0;
for(int i=0;i<n;i++) {
scanf("%d",&a);
sum+=a;
}
scanf("%d",&m);
for(int i=0;i<m;++i)
scanf("%d",&a);
if(sum==0)
printf("0.00\n");
else if(n==m)
printf("inf\n");
else
printf("%.2lf\n",1.0*sum/(n-m));
}
return 0;
}