HDU-2845-Beans-简单dp

http://acm.hdu.edu.cn/showproblem.php?pid=2845

Beans

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3749    Accepted Submission(s): 1792


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
HDU-2845-Beans-简单dp_第1张图片

Now, how much qualities can you eat and then get ?
 

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
 

Output
For each case, you just output the MAX qualities you can eat and then get.
 

Sample Input
   
   
   
   
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
 

Sample Output
   
   
   
   
242
 

 思路:

直接对 每一行,用dp求得当前行能选到的最大值

再对   n行里面用dp求得最大的总值

#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
#include <iostream>
#include <queue>
#include <map>
#include <set>
#include <vector>
using namespace std;
__int64 max(__int64 a,__int64 b)
{return a<b?b:a;}

vector <__int64 > tm[200005]; 
__int64 big[200005];
__int64 dp[200005];
__int64 dp2[200005];

int main()
{
	__int64 i,n,m;
	__int64 tmp;
	__int64 j;
	while(	scanf("%I64d%I64d",&n,&m)!=EOF)
	{ 
		for (i=1;i<=n;i++)
		{
			tm[i].clear();
			for (j=1;j<=m;j++)
			{
				scanf("%I64d",&tmp); 
				tm[i].push_back(tmp);
			}
		} 
		
		
		for (i=1;i<=n;i++)
		{ 
			dp2[0]=tm[i][0];
			dp2[1]=max(tm[i][0],tm[i][1]);
			for (j=2;j<tm[i].size();j++)
			{
				dp2[j]=max(dp2[j-2]+tm[i][j],dp2[j-1]);
			} 
			big[i]=dp2[tm[i].size()-1]; 
		}
		
		dp[1]=big[1]; 
		for (i=2;i<=n;i++)
		{
			dp[i]=max(dp[i-2]+big[i],dp[i-1]);
		}
		
		printf("%I64d\n",dp[n]);
	}
	return 0;
	
}


你可能感兴趣的:(HDU-2845-Beans-简单dp)