hdu 1068 Girls and Boys 二分图匹配 最大独立集

Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input
   
   
   
   
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0

Sample Output
   
   
   
   
5 2

最大独立数=顶点数 最大匹配数 


#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
#include<cstdio>
#include<cstdlib>
using namespace std;
vector<int> g[1505];
bool visited[1505];
int linker[1505];//记录与当前节点相连的结点
int n;//图的结点个数
bool dfs(int u)
{
    for(int i=0;i<g[u].size();i++)
        if(!visited[g[u][i]])
        {
            visited[g[u][i]]=1;
            if(linker[g[u][i]]==-1||dfs(linker[g[u][i]]))
            {
                linker[g[u][i]]=u;
                return true;
            }
        }
        return false;
}
int hungary()//匈牙利算法,返回最大匹配数的2倍
{
    int num=0;
    memset(linker,-1,sizeof(linker));
    for(int u=0;u<=n-1;u++)
    {
        memset(visited,0,sizeof(visited));
        if(dfs(u))
            num++;
    }
    return num;
}
int main()
{
    while(cin>>n)
    {
        for(int i=0;i<=1500;i++)
            g[i].clear();
        char ch1,ch2,ch3;
        for(int i=0;i<=n-1;i++)
        {
            int a,k;
            cin>>a>>ch1>>ch2>>k>>ch3;
            while(k--)
            {
                int b;
                cin>>b;
                g[a].push_back(b);
                g[b].push_back(a);
            }
        }
        cout<<n-hungary()/2<<endl;
    }
    return 0;

}


你可能感兴趣的:(二分图,最大独立集)