hust 1010 The Minimum Length(KMP求最小循环节)

The Minimum Length
               Time Limit:1000MS     Memory Limit:131072KB     64bit IO Format:%lld & %llu

Description

There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd  efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.

Input

Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.

Output

For each line, output an integer, as described above.

Sample Input

bcabcab
efgabcdefgabcde

Sample Output

3
7


最小循环节:http://www.cnblogs.com/jackge/archive/2013/01/05/2846006.html


#include <stdio.h>
#include <cstring>
#define N 1000005
char str[N];
int next[N];
void getNext(int len)
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<len)
    {
        if(j==-1||str[i]==str[j])
        {
            i++;j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
int main()
{
    while(~scanf("%s",str))
    {
        int len=strlen(str);
        getNext(len);
        printf("%d\n",len-next[len]);
    }

    return 0;
}



你可能感兴趣的:(hust 1010 The Minimum Length(KMP求最小循环节))