HDU 1856(求并查集里元素的个数)

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 14582    Accepted Submission(s): 5358


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input
   
   
   
   
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8

Sample Output
   
   
   
   
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 其实这题就是求并查集中集合元素最多的个数,,一开始我没想出来怎么弄 ==。。 只需要借助一个求集合中元素个数的数组sum,如果两个集合合并,则将一个集合的根值加到另一个集合的根值中就能求出这个集合中的元素个数。当然,由题目知个数最小为1
#include<stdio.h>
const int num = 10000001;
int p[num], sum[num];
int find(int x) {return p[x] == x ? x : p[x] = find(p[x]);}

int main()
{
    int n, i, a, b;

    while(~scanf("%d", &n))
    {
        for(i=1; i<=num; i++) p[i] = i, sum[i] = 1;
        int maxn = 1;
        for(i=1; i<=n; i++)
        {
            scanf("%d%d", &a,&b);
            int x = find(a);
            int y = find(b);
            if(x != y)
            {
                p[x] = y; //x和y都是集合的根
                sum[y] += sum[x];
                if(sum[y] > maxn) maxn = sum[y];
                //printf("sum[x]=%d, sum[y]=%d\n", sum[x],sum[y]);
            }
        }
        //printf("%d %d %d\n", sum[1],sum[2],sum[6]);
        printf("%d\n", maxn);
    }
    return 0;
}

你可能感兴趣的:(并查集)