Constructing Roads(HDU 1102)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13800 Accepted Submission(s): 5241


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input
   
   
   
   
3 0 990 692 990 0 179 692 179 0 1 1 2

Sample Output
   
   
   
   
179

错了n次,看来还是不够理解MST啊。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int p[1105], w[15010]; //本来数组5000就够了,谁知RTE
int find(int x) {return p[x] == x ? x : p[x] = find(p[x]);}
int cmp(const int i,const int j) {return w[i] < w[j];}
int main()
{
    int n, i, j;
    int r[15010], u[15010], v[15010];

    while(~scanf("%d", &n))
    {
        //int m = n*(n+1)/2;
        int g = 1; //g-1代表边的条数
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                u[g] = i; //刚开始把u[g]放第一个for循环里去了,WA
                v[g] = j; //u,v,w需在同一条边时赋值
                scanf("%d", &w[g++]);
            }
        }
        for(i=1; i<=n; i++) p[i] = i;
        for(i=1; i<g; i++) r[i] = i; //g-1才相当于边数啊,初始化
        sort(r+1,r+g,cmp); //注意g的值
        int Q, a, b;
        scanf("%d", &Q);
        for(i=1; i<=Q; i++)
        {
            scanf("%d%d", &a,&b);
            int x = find(a);
            int y = find(b);
            if(x != y) p[x] = y;
        }
        int ans = 0;
        for(i=1; i<g; i++) //这里也是边数g-1 !!!
        {
            int e = r[i];
            int x = find(u[e]);
            int y = find(v[e]);
            if(x != y)
            {
                ans += w[e];
                p[x] = y;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


你可能感兴趣的:(并查集,MST,ACMICPC)