CodeForces 630 H. Benches(组合数学)

Description
一座城市有n条南北走向的街道和n条东西走向的街道,现要将5条不用的长凳放置在街道相交处,且同一条街道上的长凳数不超过一条,问有多少种放置方案
Input
一个整数n表示街道数(5<=n<=100)
Output
长凳的放置方案数
Sample Input
5
Sample Output
120
Solution
简单组合,ans=A(5,5)*C(n,5)*C(n,5)=120*C(n,5)^2
Code

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
int n;
ll C(int n,int m)
{
    ll ans=1ll;
    if(n-m>m)m=n-m;
    for(int i=1;i<=n-m;i++)
        ans=ans*(m+i)/i;
    return ans;
}
int main()
{
    while(~scanf("%d",&n))
        printf("%I64d\n",120ll*C(n,5)*C(n,5));
    return 0;
}

你可能感兴趣的:(CodeForces 630 H. Benches(组合数学))