hdu1116——Play on Words

Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
 

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".
 

Sample Input
   
   
   
   
3 2 acm ibm 3 acm malform mouse 2 ok ok
 

Sample Output
   
   
   
   
The door cannot be opened. Ordering is possible. The door cannot be opened.
 

Source
Central Europe 1999
 

Recommend


一开始建边的方向考虑错了,于是超时,后来发现可以对每个单词的首尾字母相连,然后最后考虑出入度,其实就是判断图的连通性和欧拉通路或者回路是否存在

#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

const int N=100010;
int father[N];
char str[1010];
bool vis[26];
int in[26];
int out[26];

int find(int x)
{
	if(father[x]==-1)
		return x;
	return father[x]=find(father[x]);
}

void merge(int x,int y)
{
	int a=find(x);
	int b=find(y);
	if(a!=b)
		father[a]=b;
}

void init()
{
	memset(father,-1,sizeof(father));
	memset(in,0,sizeof(in));
	memset(out,0,sizeof(out));
	memset(vis,0,sizeof(vis));
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		init();
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%s",str);
			int len=strlen(str);
			if(vis[str[len-1]-'a']==0)
				vis[str[len-1]-'a']=1;
			if(vis[str[0]-'a']==0)
				vis[str[0]-'a']=1;
			in[str[len-1]-'a']++;
			out[str[0]-'a']++;
			merge(str[len-1]-'a',str[0]-'a');
		}
		int block=0;
		for(int i=0;i<26;i++)
		{
			if(vis[i] && father[i]==-1)
				block++;
		}
		if(block!=1)
			printf("The door cannot be opened.\n");
		else
		{
			int cnt=0;
			bool flag=false;
			for(int i=0;i<26;i++)
			{
				if(out[i]==in[i])
					continue;
				else
				{
					if(out[i]!=in[i]+1 && in[i]!=out[i]+1)
					{
						flag=true;
						break;
					}
					else
						cnt++;
					if(cnt>2)
						break;
				}
			}
			if(flag)
				printf("The door cannot be opened.\n");
			else
				if(cnt>2 || cnt==1)
					printf("The door cannot be opened.\n");
				else
					printf("Ordering is possible.\n");
		}
	}
	return 0;
}




你可能感兴趣的:(并查集)