数学—杭电1030 Delta-wave

http://acm.hdu.edu.cn/showproblem.php?pid=1030

Delta-wave

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5272    Accepted Submission(s): 1986

Problem Description
A triangle field is numbered with successive integers in the way shown on the picture below.

数学—杭电1030 Delta-wave_第1张图片

The traveller needs to go from the cell with number M to the cell with number N. The traveller is able to enter the cell through cell edges only, he can not travel from cell to cell through vertices. The number of edges the traveller passes makes the length of the traveller's route.

Write the program to determine the length of the shortest route connecting cells with numbers N and M.
 
Input
Input contains two integer numbers M and N in the range from 1 to 1000000000 separated with space(s).
 
Output
Output should contain the length of the shortest route.
 
Sample Input
   
   
   
   
6 12
 
Sample Output
   
   
   
   
3

 

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    int n,m;
    int nx,ny,nz,mx,my,mz;
    while(cin>>n>>m)
    {
    nx=(int)sqrt(double(n-1))+1;
    mx=(int)sqrt(double(m-1))+1;
    ny=abs((nx-1)*(nx-1)+1-n)/2+1;
    my=abs((mx-1)*(mx-1)+1-m)/2+1;
    nz=abs(nx*nx-n)/2+1;
    mz=abs(mx*mx-m)/2+1;
    cout<<abs(nx-mx)+abs(ny-my)+abs(nz-mz)<<endl;
    }
    return 0;
}

你可能感兴趣的:(数学—杭电1030 Delta-wave)