ZOJ3869:Ace of Aces(浙江省赛2015)

The 12th Zhejiang Provincial Collegiate Programming Contest 

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input

3
5
2 2 2 1 1
5
1 1 2 2 3
1
998

Sample Output

2
Nobody
998



题意:找出出现次数最多的数,如果有多个输出Nobody


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
#define ls 2*i
#define rs 2*i+1
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,x) memset(a,x,sizeof(a))
#define w(a) while(a)
#define LL long long
const double pi = acos(-1.0);
#define Len 20005
#define mod 19999997
const int INF = 0x3f3f3f3f;

int t,n,a,maxn,flag;

struct node
{
    int cnt,id;
}hsh[1005];

int cmp(node a,node b)
{
    return a.cnt<b.cnt;
};

int main()
{
    int i;
    scanf("%d",&t);
    w(t--)
    {
        scanf("%d",&n);
        mem(hsh,0);
        up(i,0,n-1)
        {
            scanf("%d",&a);
            hsh[a].id = a;
            hsh[a].cnt++;
        }
        sort(hsh,hsh+1001,cmp);
        if(hsh[1000].cnt==hsh[999].cnt)
            printf("Nobody\n");
        else
            printf("%d\n",hsh[1000].id);
    }

    return 0;
}


你可能感兴趣的:(ZOJ)